Is anybody using the C++ Client on MacOS?

I’m having some difficulty building the C++ Client on MacOS. I believe I’ve followed all the steps in the readme, but when I try to build I get linker errors complaining about missing symbols.

If you’ve implemented the C++ Client on MacOS I would love to compare notes.


Hi @Mehoo462,

Please can you share the exact error message you’re receiving? What version of the C++ client SDK are you using?

Hi Tom,

Thanks for your interest. Below are the details of the situation.

I’ve tried with release 2.4.0, 2.4.1, 2.5.0, and 2.5.1. I have two test systems. One is running MacOS 10.11, the other is running MacOS 12.2.1 on an M1 chip. I get the same error on both systems on all versions of the SDK. Please let me know if I can provide any additional information. I’m very eager to resolve this.

I have tried my best to follow the instructions in the readme. I suspect that I’m doing something wrong or there are steps missing from the readme.

The issue is linker errors at buildtime. They appear to be related to Boost?
Testing with a very basic command line program. The problem occurs when I call createDefaultClient(). If I comment out line 23, it builds successfully. But, of course, that line is essential for any further progress.

Header and library search paths are set:

All .a Files, security framework, and foundation framework are added.

The Log:

Linker Command Failed with Exit Code 1

Thanks again for any assistance. I hope I can get this up and running.

Hi @tom ,

Was wondering if you have any insights here? This seems like a pretty fundamental issue. I think I’m following the directions. Either I’m doing something wrong, or there are steps missing from the instructions.

If anybody has successfully built the MacOS client library I’d love to understand what they are doing differently.