Error read storage

I faced to this error when I try to read storage after passing 2 or 3 hours time after start session

ApiResponseException: {“code”:13, “message”:“Error reading storage objects.”}
Nakama.ApiClient.ReadStorageObjectsAsync (System.String bearerToken, Nakama.ApiReadStorageObjectsRequest body, System.Nullable`1[T] cancellationToken) (at :0)

Good day :smiley:

Yesterday, I encountered a similar problem and after 6 hours of troubleshooting, the solution that helped me was as follows:

Next, I did the following (Please don’t repeat without thinking!):

  • Deleted the file named .cookie.
  • In the console, I typed docker volume ls to see the existing data.
  • Then, I used this command to delete old data - docker volume rm $(docker volume ls -q)
  • After that, docker-compose down
  • Then, docker-compose up -d
  • Finally, docker compose up

After these steps, my code for loading data from the documentation finally started working. I performed the same actions on the production project I’m working on, and everything worked there as well. Prior to this, I had tried various ways to load data from the server, but all in vain.
It turned out that everything was working fine. Apparently, there was a version mismatch between the database and Nakama. Here are some additional screenshots that might help:

I apologize for any possible errors in conveying my thoughts as I do not know English well. :sweat_smile:
I sincerely wish you all the best :heart:

1 Like

Thanks. I sove it just with delete volume and compose again but this is not good because all of data were cleaned!

1 Like