Unable to use nakama-unreal plugin on fresh created project in UE5


I’m new to Nakama and I’m trying to do some PoCs with it to see what we can build using this amazing playcentric game services.

As the first step, I created a new project with the third person template from my UE5 installation.
I followed the steps, getting the released version on github and copy the folder Nakama to my Plugins project.

After do this, I got the following error:


If I click yes, I got the following message:

“SampleProject” could not be compiled. Try rebuild from source manually."

This message is from the release : v2.5.0-r1

I also tried the last release and this is the result and the same message appears, but compling about:


Could you someone tell me what I’m doing wrong?

Additional information: I’m using a Windows 11 machine.

Hi @erik-paula,

can you try out the latest version? Release v2.7.0 · heroiclabs/nakama-unreal · GitHub

I already tried.
Am I missing any local build process?

Can you double-check this step?

Also, please ensure your Unreal project is a C++ project. If it is Blueprint only, you can add a new C++ file to your project in Unreal Editor via “File → New C++ Class”. Set it private and name it whatever you like. Having this file in your project lets Unreal compile the plugin.

Oh! This is the problem!
My project was exclusively blueprint!

Thank you.