Typos, potential improvement Godot wallet docs

Hi, in the wallet access section of the Godot Sdk docs, here, it states:

var account : NakamaAPI.ApiAccount = yield(client.get_account_async(session), "completed")
var wallet = JSON.parse(account.wallet) #Missing result, returns a simpler json
for currency in wallet #missing :
    Print("%s, %s" % [currency, wallet[currency].string(int from)]) #I'm not sure here, but int from is deprecated? Also Print is with a capital P, should be print.

But apart from some typos, it could be simplified and also added error checking:

	var account : NakamaAPI.ApiAccount = yield(client.get_account_async(session), "completed")
	if account.is_exception():
		print("Error: ", account)
	var wallet = JSON.parse(account.wallet).result
	if wallet.empty():
		print("Empty Json")
	else:
		print(wallet["Your_Key_Here"]) #Simple to access whatever value you need from the wallet, if the wallet is complex, then do something else like the loop or whatever.

The conclusion of my code may be too simple, but works. :slight_smile: