Crashes on IOS with nakama dynamic library


  1. Versions: Nakama SDK version 2.4
  2. Server Framework Runtime language: Go

We can not launch client on our IOS device. Android client works without problems.

Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Description: DYLD, dyld: Using shared cache: D7F84FC0-3317-3485-AB1C-3D54AA184E40 | dependent dylib '@rpath/libnakama-cpp.dylib' not found for '/private/var/containers/Bundle/Application/45D9D5A0-CEE0-400A-8536-25A2F0505B9F/', tried but didn't find: '/private/var/containers/Bundle/Application/45D9D5A0-CEE0-400A-8536-25A2F0505B9F/' '@rpath/libnakama-cpp.dylib' '/usr/local/lib/libnakama-cpp.dylib' '/usr/lib/libnakama-cpp.dylib'
Highlighted by Thread:  0

Backtrace not available

Unknown thread crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000006   x1: 0x0000000000000001   x2: 0x000000016f1b9fe0   x3: 0x000000000000009f
    x4: 0x000000016f1b9be0   x5: 0x0000000000000000   x6: 0x0000000000000000   x7: 0x0000000000000000
    x8: 0x0000000000000020   x9: 0x0000000000000009  x10: 0x0000000000000001  x11: 0x000000000000004f
   x12: 0x00000000000000c0  x13: 0x0000000000000033  x14: 0x0000000000000017  x15: 0x0000000000000034
   x16: 0x0000000000000209  x17: 0x00000001139fb488  x18: 0x0000000000000000  x19: 0x0000000000000000
   x20: 0x000000016f1b9be0  x21: 0x000000000000009f  x22: 0x000000016f1b9fe0  x23: 0x0000000000000001
   x24: 0x0000000000000006  x25: 0x000000016f1ba8a8  x26: 0x0000000113a24000  x27: 0x0000000113a24000
   x28: 0x000000016f1bb914   fp: 0x000000016f1b9bb0   lr: 0x0000000113a09a88
    sp: 0x000000016f1b9b70   pc: 0x0000000113a01848 cpsr: 0x00000000
   esr: 0x00000000  Address size fault

Hi @Elagin - can you please mention what client library you are using and on what iOS device? What engine have you used to build your game?

Hi! Thank you for reply. We are using Unreal engine and Unreal sdk. So we find out that Unreal sdk use c++ library. Firstly we used prebuilded library and get this error, then we build it manually and get the same error

@mofirouz we test it on Iphone XR with ios 14 onboard

Thanks. Do you have an idea of where in your code this happens? Eg are you init the client or calling a function or connecting to the server?

Do you have a stacktrace that shows more details?

@mofirouz it happens when we call createDefaultClient in our GameInstance Init function, so we get crash on launch

Thanks @Elagin - can you please create a minimal example demonstrating the issue, and open an issue in the tracker here (with the example):