Forever stuck in starting console server gateway for HTTP

I’m starting a tutorial of how to use Nakama with Godot however I have had troubles for more than 4 days in trying to make it work.

One of the problems that happens frequently is that I write the command {docker-compose up} with the .yml already edited as it is in the documentation. However the console gets stuck in “starting console server gateway for HTTP request” and after that nothing happens for an hour or more.

As I can see, when you get the message of startup done it means that I can already continue with the next part of the tutorial, but the console never finishes with that line.

What should I’ll be looking for? What information can I give you to help my situation? (Sorry I’m just starting with this, framework?)

Windows 8.1
Docker Toolbox
I’m using the Docker Quickstart Terminal

Hi @Chears welcome to the Heroic Labs community forums. Have you made any edits to your docker file?

Thanks for the welcome! I’ve should probably presented myself first. :sweat_smile:

No, I tried uninstalling and installing docker toolbox again but nothing changed. I had a default problem and a missing config file. However, out of curiosity I opened another app that was installed called Kinematic, and the app itself troubleshoot some problems that it had and fix two default problems that I’ve encountered. (It’s been a rocky path)

So my guess is that there have been changes in the docker files but I haven’t changed the files directly outside of the docker-compose.yml

I notice the files are in Users/Chears as .docker. Do you mean those files?
What should I’ll be looking for?
Do you need a capture or list of files within?

1 Like

@Chears Have you checked if you can reach the developer console on that port? By default it’s http://127.0.0.1:7351.

If you can reach it then what you’re seeing is a well-known issue with Docker Toolbox on Windows which sometimes does not flush log lines to the terminal until the next log is written. Since “startup done” would be the very last initial log message printed it may just not appear until the next log message after that.

You can usually work around this by adding tty: true to the nakama container spec in the docker-compose.yml file.

Within Nakama: I added tty: true And it worked. I tried multiple times, sometimes it gets stuck on other parts (that also happened before) but it seems that when it works it does gets the Startup done message :smiley:

however, how do I check if I can reach the developer console on that port? I tried http://127.0.0.1:7351 .` on my browser which is chrome and I don’t get anything. So maybe that’s not how I have access to the developer console

I’m not sure if I should create another topic. If so please tell me. I am putting it here since it’s regarding something that was asked in here about being able to access the developer console.

I try to do something daily even if it’s small in order to proceed.

First Problem Solved

-This time I checked a little more and discover that the docker toolbox quickstart terminal didn’t have an IP at the beggining so I google it and saw that you could erase the virtual images and the toolbox would automatically create a new default with an IP, and now it showed me the IP at the beggining.

Second Problem Solved

Still no access to developer console so I tried to understand the messages on the console and notice that nakama 1 exited because of errors so I google it again and found the following answer.

This has setup a Docker volume for your compose file. You should wipe the volumes or just purge the environment with docker-compose -f ./docker-compose.yml down -v . The -v flag will purge the volume as well.

I did so and it worked, no longer was nakama 1 exiting and the final message was setup done. And now it is consistent, I always get that message.
.

However, still no access to the developer console.

I discovered how to copy the text of the console, so that might help. Here’s the link.

My question is: What am I missing in order to have access to the developer console at http://127.0.0.1:7351/ ?

Hi @Chears I’m glad to hear your first two hurdles have been solved :slight_smile:

For you Nakama Console issue, could you compare your setup against one of our server runtime setup tutorials and see if you are doing anything different Nakama Server Runtime Code Project Setup using TypeScript - YouTube