Server will not run on ubuntu

I was trying to run the server on a ubuntu computer, but when I tried to run “sudo docker-compose up” it gives an error.

nakama | {“level”:“fatal”,“ts”:“2020-10-27T00:56:55.744Z”,“caller”:“main.go:133”,“msg”:“Failed initializing runtime modules”,“error”:"/nakama/data/modules/._world_control.lua line:1(column:1) near ‘\u0000’: Invalid token\n"}

Does anyone know what this means?
Also everything works fine on MacOS.

Based on your log message the server does run, but fails to load your Lua runtime module(s).

Looks like your ._world_control.lua file is not properly UTF-8 encoded. Check if it’s UTF-16 or has an unexpected BOM, and convert it to standard UTF-8 instead before loading it into the server.

Just tried to save the Lua files with encoding UTF-8 using sublime, but it’s still giving the same error message. Is there something else that could be causing the problem or am I doing something wrong?

You can look for and strip out ASCII NUL characters (the \u0000 in your error) and strip them out. Unless you’ve put those in there explicitly they’re usually unwanted artefacts of copy/pasting text, or file encoding across OS/file systems etc.

Thanks for the help, I’m not exactly sure what the problem was but when I decided to try recreating the file and copy the code over from the old ones it started working.