Nakama can't connect to CockroachDB hosted in Cockroach Labs (dial error (timeout: dial tcp 34.236.31.209:2657: i/o timeout))

Hey Nakama team,

I’m having issues connecting to my CockroachDB cluster hosted on Cockroach Labs on my new laptop running Fedora 37. I am able to connect to my CockroachDB cluster using DBeaver on my laptop but Nakama is having issues connecting. I keep seeing this error on both the Linux binary (3.15.0) and the docker image 3.15.0

{"level":"info","ts":"2023-01-18T23:33:56.764-0500","caller":"v3/main.go:124","msg":"Database connections","dsns":["uuu:xxxxx@myhost.cockroachlabs.cloud:26257"]}
{"level":"debug","ts":"2023-01-18T23:33:57.161-0500","caller":"server/db.go:69","msg":"Complete database connection URL","raw_url":"postgres://uuu:xxxxx@myhost.cockroachlabs.cloud:26257/nakama?sslmode=prefer"}
{"level":"fatal","ts":"2023-01-18T23:34:12.162-0500","caller":"server/db.go:81","msg":"Error pinging database","error":"failed to connect to `host=myhost.cockroachlabs.cloud user=uuu database=nakama`: dial error (timeout: dial tcp 34.236.31.209:26257: i/o timeout)"}

I’ve tried adding ?sslmode=verify-full and leaving it blank but neither works. This was working a few days ago on my Windows Desktop (using Docker 3.15.0) but on my Fedora machine looks like it’s broken

If I run the cockroachdb docker container like in the nakama docker-compose getting started guide everything works but connecting to my already establish database is causing issues