Https interfering with Nakama?

I’ve been using Google Compute Engine to run my Nakama server and it’s been working fine until recently. I purchased a domain name, installed Apache and put my HTML5 Godot client on the webserver. Still worked fine until I used Certbot to configure/enable https on the domain. I just used Certbot’s automatic command rather than go through the steps myself but now anyone trying to authenticate/connect gets a HTTPRequest failed error.

I have access to the certificates and I tried putting them under socket.ssl_certificate/ssl_private_key, I also tried changing my Nakama.create_client call to use https instead of http for its server scheme but still the same error.

The result of the authentication request is 6 (with HTTP scheme) or 5 (with HTTPS scheme) and response code 0.

Edit: I switched my client’s host to the domain name instead of its static IP and now I get further, but instead get this error:
{code:14, message:connection error: desc = “transport: authentication handshake failed: x509: cannot validate certificate for because it doesn’t contain any IP SANs”}

Do I need to do anything with port 443? I’ve been using port 7350 as recommended/default

Also the documentation says not to use ssl_certificate & ssl_private_key options in production environment, what would I do instead?

@Shikadi I think the root cause of this is covered in the issue on the tracker: . There’s a patch on master which should resolve the situation. Have a look and check its the same as the error you’ve described.