# Https interfering with Nakama?

**URL:** <https://forum.heroiclabs.com/t/https-interfering-with-nakama/1113>\
**Category:** Game Design\
**Created:** [November 7, 2020, 3:08am UTC](https://forum.heroiclabs.com/t/https-interfering-with-nakama/1113 "2020-11-07T03:08:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shikadi](https://avatars.discourse-cdn.com/v4/letter/s/bcef8e/32.png) [@Shikadi](https://forum.heroiclabs.com/u/Shikadi)\
**Post date:** [November 7, 2020, 3:08am UTC](https://forum.heroiclabs.com/t/https-interfering-with-nakama/1113/1 "2020-11-07T03:08:08Z")

</div>

I’ve been using Google Compute Engine to run my Nakama server and it’s been working fine until recently. I purchased a domain name, installed Apache and put my HTML5 Godot client on the webserver. Still worked fine until I used Certbot to configure/enable https on the domain. I just used Certbot’s automatic command rather than go through the steps myself but now anyone trying to authenticate/connect gets a HTTPRequest failed error.

I have access to the certificates and I tried putting them under socket.ssl\_certificate/ssl\_private\_key, I also tried changing my Nakama.create\_client call to use https instead of http for its server scheme but still the same error.

The result of the authentication request is 6 (with HTTP scheme) or 5 (with HTTPS scheme) and response code 0.

Edit: I switched my client’s host to the domain name instead of its static IP and now I get further, but instead get this error:  
{code:14, message:connection error: desc = “transport: authentication handshake failed: x509: cannot validate certificate for 127.0.0.1 because it doesn’t contain any IP SANs”}

---

<div class="post-metadata">

**Author:** ![Shikadi](https://avatars.discourse-cdn.com/v4/letter/s/bcef8e/32.png) [@Shikadi](https://forum.heroiclabs.com/u/Shikadi)\
**Post date:** [November 9, 2020, 5:34am UTC](https://forum.heroiclabs.com/t/https-interfering-with-nakama/1113/2 "2020-11-09T05:34:43Z")

</div>

Do I need to do anything with port 443? I’ve been using port 7350 as recommended/default

Also the documentation says not to use ssl\_certificate & ssl\_private\_key options in production environment, what would I do instead?

---

<div class="post-metadata">

**Author:** ![novabyte](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.heroiclabs.com/novabyte/32/1324_2.png) [@novabyte](https://forum.heroiclabs.com/u/novabyte)\
**Post date:** [November 10, 2020, 9:04pm UTC](https://forum.heroiclabs.com/t/https-interfering-with-nakama/1113/3 "2020-11-10T21:04:42Z")

</div>

@Shikadi I think the root cause of this is covered in the issue on the tracker: [https://github.com/heroiclabs/nakama/issues/348](https://github.com/heroiclabs/nakama/issues/348) . There’s a patch on master which should resolve the situation. Have a look and check its the same as the error you’ve described.
