# Digital Ocean App Issue

**URL:** <https://forum.heroiclabs.com/t/digital-ocean-app-issue/4706>\
**Category:** Local Setup\
**Tags:** server-framework\
**Created:** [December 8, 2023, 11:48am UTC](https://forum.heroiclabs.com/t/digital-ocean-app-issue/4706 "2023-12-08T11:48:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sathyaraj](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.heroiclabs.com/sathyaraj/32/1905_2.png) [@Sathyaraj](https://forum.heroiclabs.com/u/Sathyaraj)\
**Post date:** [December 8, 2023, 11:48am UTC](https://forum.heroiclabs.com/t/digital-ocean-app-issue/4706/1 "2023-12-08T11:48:50Z")

</div>

Hi, I was able to create a droplet in DigitalOcean and deploy the Nakama server successfully, Now I am trying to create a DigitalOcean App instead of a Droplet to make use of auto-scaling and CI/CD.  
I get the following error related to DB. Not sure how to solve it.

```auto
{"level":"fatal","ts":"2023-12-08T09:53:38.100Z","caller":"server/db.go:86","msg":"Error pinging database","error":"failed to connect to `host=localhost user=root database=nakama`: dial error (dial tcp [::1]:26257: connect: connection refused)"}

```

Here is my docker-compose file

```auto
version: '3'
services:
  postgres:
    command: postgres -c shared_preload_libraries=pg_stat_statements -c pg_stat_statements.track=all
    environment:
      - POSTGRES_DB=nakama
      - POSTGRES_PASSWORD=localdb
    expose:
      - "8080"
      - "5432"
    image: postgres:12.2-alpine
    ports:
      - "5432:5432"
      - "8080:8080"
    volumes:
      - data:/var/lib/postgresql/data

  nakama:
    build: .
    depends_on:
      - postgres
    entrypoint:
      - "/bin/sh"
      - "-ecx"
      - >
        /nakama/nakama migrate up --database.address postgres:localdb@postgres:5432/nakama &&
        exec /nakama/nakama --config /nakama/data/local.yml --database.address postgres:localdb@postgres:5432/nakama        
    expose:
      - "7349"
      - "7350"
      - "7351"
    healthcheck:
      test: ["CMD", "/nakama/nakama", "healthcheck"]
      interval: 10s
      timeout: 5s
      retries: 5
    links:
      - "postgres:db"
    ports:
      - "7349:7349"
      - "7350:7350"
      - "7351:7351"
    restart: unless-stopped

volumes:
  data:

```

---

<div class="post-metadata">

**Author:** ![mofirouz](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.heroiclabs.com/mofirouz/32/1523_2.png) [@mofirouz](https://forum.heroiclabs.com/u/mofirouz)\
**Post date:** [December 8, 2023, 1:48pm UTC](https://forum.heroiclabs.com/t/digital-ocean-app-issue/4706/2 "2023-12-08T13:48:53Z")

</div>

We can’t advise on custom deployments because we don’t have access to the infrastructure and there are too many different variants. If you need an easy auto-scalable solution, use Heroic Cloud which will also fund the development of the Open-Source technology.

---

<div class="post-metadata">

**Author:** ![Sathyaraj](https://sea2.discourse-cdn.com/flex020/user_avatar/forum.heroiclabs.com/sathyaraj/32/1905_2.png) [@Sathyaraj](https://forum.heroiclabs.com/u/Sathyaraj)\
**Post date:** [December 11, 2023, 6:19am UTC](https://forum.heroiclabs.com/t/digital-ocean-app-issue/4706/3 "2023-12-11T06:19:42Z")

</div>

Certainly, Once the game is published and has a good userbase we can move to the heroic cloud, Till then $600 per title would be too steep. That’s the reason we are planning to host on our own.
